summaryrefslogtreecommitdiff
path: root/bin/domain/imag-contact/Cargo.toml
blob: 56f1a95979e054e54352604534bbb5e7cad56bd6 (plain)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
[package]
name = "imag-contact"
version = "0.7.0"
authors = ["Matthias Beyer <mail@beyermatthias.de>"]

description = "Part of the imag core distribution: imag-contact command"

keywords    = ["imag", "PIM", "personal", "information", "management"]
readme      = "../../../README.md"
license     = "LGPL-2.1"

documentation = "https://matthiasbeyer.github.io/imag/imag_documentation/index.html"
repository    = "https://github.com/matthiasbeyer/imag"
homepage      = "http://imag-pim.org"

build = "../../../build.rs"

[badges]
travis-ci                         = { repository = "matthiasbeyer/imag" }
is-it-maintained-issue-resolution = { repository = "matthiasbeyer/imag" }
is-it-maintained-open-issues      = { repository = "matthiasbeyer/imag" }
maintenance                       = { status     = "actively-developed" }

[dependencies]
log = "0.4.0"
toml = "0.4"
toml-query = "0.6"
handlebars = "0.29"
vobject     = "0.4"
walkdir = "1"
uuid = { version = "0.6", features = ["v4"] }
serde_json = "1"

libimagrt          = { version = "0.7.0", path = "../../../lib/core/libimagrt" }
libimagstore       = { version = "0.7.0", path = "../../../lib/core/libimagstore" }
libimagerror       = { version = "0.7.0", path = "../../../lib/core/libimagerror" }
libimagutil        = { version = "0.7.0", path = "../../../lib/etc/libimagutil" }
libimagentryref    = { version = "0.7.0", path = "../../../lib/entry/libimagentryref" }
libimagentryedit   = { version = "0.7.0", path = "../../../lib/entry/libimagentryedit" }
libimaginteraction = { version = "0.7.0", path = "../../../lib/etc/libimaginteraction" }

[dependencies.libimagcontact]
version          = "0.7.0"
path             = "../../../lib/domain/libimagcontact"
default-features = false
features         = ["deser"]

[dependencies.clap]
version = ">=2.29"
default-features = false
features = ["color", "suggestions"]